about summary refs log tree commit diff stats
path: root/shell.nix
diff options
context:
space:
mode:
authorAlan Pearce2024-05-12 22:34:23 +0200
committerAlan Pearce2024-05-12 23:12:39 +0200
commit895a3b061bb4717955ffbceab3bf3c6ecebacd70 (patch)
treefed970785b9b0460693d07dcffae08283be90ce4 /shell.nix
parent7077a3748fa545e8dee83d4f3464c55b4b459183 (diff)
downloadsearchix-895a3b061bb4717955ffbceab3bf3c6ecebacd70.tar.lz
searchix-895a3b061bb4717955ffbceab3bf3c6ecebacd70.tar.zst
searchix-895a3b061bb4717955ffbceab3bf3c6ecebacd70.zip
build: switch to flakes
Diffstat (limited to 'shell.nix')
-rw-r--r--shell.nix38
1 files changed, 2 insertions, 36 deletions
diff --git a/shell.nix b/shell.nix
index 2e85e8c..d2c4c45 100644
--- a/shell.nix
+++ b/shell.nix
@@ -1,37 +1,3 @@
-{ pkgs ? (
-    let
-      sources = import ./nix/sources.nix;
-    in
-    import sources.nixpkgs {
-      overlays = [
-        (import "${sources.gomod2nix}/overlay.nix")
-        (import ./nix/overlays/default.nix)
-      ];
-    }
-  )
-}:
+{ system ? builtins.currentSystem }:
 
-let
-  goEnv = pkgs.mkGoEnv { pwd = ./.; };
-  searchix = import ./default.nix {
-    inherit pkgs;
-  };
-in
-pkgs.mkShell {
-  packages = with pkgs; [
-    goEnv
-
-    brotli
-    bleve
-    wgo
-    gomod2nix
-    niv
-    nixpkgs-lint
-
-    bun
-  ];
-  shellHook = ''
-    ${searchix.pre-commit-check.shellHook}
-  '';
-  buildInputs = searchix.pre-commit-check.enabledPackages;
-}
+(builtins.getFlake (toString ./.)).devShells.${system}.default