about summary refs log tree commit diff stats
path: root/shell.nix
diff options
context:
space:
mode:
authorAlan Pearce2024-05-02 13:55:48 +0200
committerAlan Pearce2024-05-02 22:40:38 +0200
commit7ad48953a4d9470d2f4fe89343c0b09bff410c58 (patch)
tree9aa74fcb05f51df6b56d1a6025217dd3c5075a4b /shell.nix
downloadsearchix-7ad48953a4d9470d2f4fe89343c0b09bff410c58.tar.lz
searchix-7ad48953a4d9470d2f4fe89343c0b09bff410c58.tar.zst
searchix-7ad48953a4d9470d2f4fe89343c0b09bff410c58.zip
chore: initial commit
Diffstat (limited to 'shell.nix')
-rw-r--r--shell.nix33
1 files changed, 33 insertions, 0 deletions
diff --git a/shell.nix b/shell.nix
new file mode 100644
index 0000000..ae73c6b
--- /dev/null
+++ b/shell.nix
@@ -0,0 +1,33 @@
+{ pkgs ? (
+    let
+      sources = import ./nix/sources.nix;
+    in
+    import sources.nixpkgs {
+      overlays = [
+        (import "${sources.gomod2nix}/overlay.nix")
+      ];
+    }
+  )
+}:
+
+let
+  goEnv = pkgs.mkGoEnv { pwd = ./.; };
+  searchix = import ./default.nix {
+    inherit pkgs;
+  };
+in
+pkgs.mkShell {
+  packages = with pkgs; [
+    goEnv
+
+    gomod2nix
+    niv
+    nixpkgs-lint
+
+    bun
+  ];
+  shellHook = ''
+    ${searchix.pre-commit-check.shellHook}
+  '';
+  buildInputs = searchix.pre-commit-check.enabledPackages;
+}