about summary refs log tree commit diff stats
path: root/flake.nix
diff options
context:
space:
mode:
authorAlan Pearce2024-05-12 23:24:03 +0200
committerAlan Pearce2024-05-13 00:46:18 +0200
commitad064dfb954a815f1e5175ab42033fc9e1fb6d02 (patch)
tree919fe8c9462acc9b663e556dc85c116035e9cee1 /flake.nix
parent895a3b061bb4717955ffbceab3bf3c6ecebacd70 (diff)
downloadsearchix-ad064dfb954a815f1e5175ab42033fc9e1fb6d02.tar.lz
searchix-ad064dfb954a815f1e5175ab42033fc9e1fb6d02.tar.zst
searchix-ad064dfb954a815f1e5175ab42033fc9e1fb6d02.zip
build: export nixos module and overlay
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix7
1 files changed, 6 insertions, 1 deletions
diff --git a/flake.nix b/flake.nix
index 389c646..82d2bd0 100644
--- a/flake.nix
+++ b/flake.nix
@@ -22,7 +22,12 @@
   };
 
   outputs = { self, nixpkgs, flake-utils, gomod2nix, pre-commit-hooks, simple-css }:
-    (flake-utils.lib.eachDefaultSystem
+    {
+      nixosModules = {
+        default = import ./nix/modules self;
+      };
+      overlays.default = import ./nix/overlays;
+    } // (flake-utils.lib.eachDefaultSystem
       (system:
         let
           pkgs = import nixpkgs {