about summary refs log tree commit diff stats
path: root/flake.nix
diff options
context:
space:
mode:
authorAlan Pearce2024-05-14 21:16:23 +0200
committerAlan Pearce2024-05-14 21:45:02 +0200
commit1a5c82e2d08accb6330c4164ab987b87157b10ed (patch)
tree48d6a913809e60b1a0cc28a8b67413ffaf979f97 /flake.nix
parentf08094f23aa4dc7d63a7c98b4429d88005fe3a2d (diff)
downloadsearchix-1a5c82e2d08accb6330c4164ab987b87157b10ed.tar.lz
searchix-1a5c82e2d08accb6330c4164ab987b87157b10ed.tar.zst
searchix-1a5c82e2d08accb6330c4164ab987b87157b10ed.zip
build: bake git hash into build for headers and --version
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix7
1 files changed, 5 insertions, 2 deletions
diff --git a/flake.nix b/flake.nix
index 48697c5..c0df6bf 100644
--- a/flake.nix
+++ b/flake.nix
@@ -41,11 +41,11 @@
           # This has no effect on other platforms.
           callPackage = pkgs.darwin.apple_sdk_11_0.callPackage or pkgs.callPackage;
         in
-        {
+        rec {
           packages.default = callPackage ./nix/package.nix {
             inherit (gomod2nix.legacyPackages.${system}) buildGoApplication;
-            css = simple-css;
             inherit self;
+            css = simple-css;
           };
           devShells.default = callPackage ./nix/dev-shell.nix {
             pre-commit-check = {
@@ -61,6 +61,9 @@
                 inherit pkgs;
               }
             );
+            buildVersion = pkgs.testers.testVersion {
+              package = packages.default;
+            };
           };
         })
     );