about summary refs log tree commit diff stats
path: root/default.nix
diff options
context:
space:
mode:
authorAlan Pearce2024-05-09 18:58:14 +0200
committerAlan Pearce2024-05-09 19:28:15 +0200
commit3b379a13710cae2adc56131af1069e6fb92976b8 (patch)
treed7801226ac84e201c6eea11a04941b1137adc78f /default.nix
parent0986e8699e87addccbef43c0ce30a466988fed15 (diff)
downloadsearchix-3b379a13710cae2adc56131af1069e6fb92976b8.tar.lz
searchix-3b379a13710cae2adc56131af1069e6fb92976b8.tar.zst
searchix-3b379a13710cae2adc56131af1069e6fb92976b8.zip
style: reformat with golines and enforce on commit
Diffstat (limited to 'default.nix')
-rw-r--r--default.nix8
1 files changed, 8 insertions, 0 deletions
diff --git a/default.nix b/default.nix
index 10f7ac7..3de02f2 100644
--- a/default.nix
+++ b/default.nix
@@ -61,6 +61,14 @@ in
       yamllint = {
         enable = true;
       };
+      golines = {
+        enable = true;
+        name = "golines";
+        description = "A golang formatter that fixes long lines";
+        types_or = [ "go" ];
+        entry = "${pkgs.golines}/bin/golines --write-output";
+        pass_filenames = true;
+      };
       go-mod-tidy = {
         enable = true;
         name = "go-mod-tidy";