summary refs log tree commit diff stats
path: root/user/settings/zsh.nix
diff options
context:
space:
mode:
Diffstat (limited to 'user/settings/zsh.nix')
-rw-r--r--user/settings/zsh.nix17
1 files changed, 9 insertions, 8 deletions
diff --git a/user/settings/zsh.nix b/user/settings/zsh.nix
index 7dffecb4..88004637 100644
--- a/user/settings/zsh.nix
+++ b/user/settings/zsh.nix
@@ -1,9 +1,9 @@
-{
-  config,
-  lib,
-  pkgs,
-  ...
-}: let
+{ config
+, lib
+, pkgs
+, ...
+}:
+let
   inherit (pkgs) stdenv;
   lsOptions =
     if stdenv.isDarwin
@@ -19,7 +19,7 @@
     src = stdenv.mkDerivation {
       inherit (attrs) src;
       name = "zsh-plugin-${attrs.name}";
-      buildInputs = [pkgs.zsh];
+      buildInputs = [ pkgs.zsh ];
       buildPhase = ''
         zsh -c 'for f in **/*.zsh; zcompile "$f"'
       '';
@@ -28,7 +28,8 @@
       '';
     };
   };
-in {
+in
+{
   home.packages = with pkgs; [
     fzf
     ghq