summary refs log tree commit diff stats
path: root/user/settings/shell.nix
diff options
context:
space:
mode:
Diffstat (limited to 'user/settings/shell.nix')
-rw-r--r--user/settings/shell.nix11
1 files changed, 10 insertions, 1 deletions
diff --git a/user/settings/shell.nix b/user/settings/shell.nix
index 6542636a..3158c1af 100644
--- a/user/settings/shell.nix
+++ b/user/settings/shell.nix
@@ -141,9 +141,18 @@ in
       sngc = "sudo nix-collect-garbage --delete-older-than 30d";
     };
   };
+  programs.gh = {
+    enable = true;
+    extensions = with pkgs; [ gh-eco ];
+    settings = {
+      git_protocol = "ssh";
+      aliases = {
+        fork = "repo fork --origin-name fork --default-branch-only";
+      };
+    };
+  };
   home.packages = with pkgs; [
     fzf
-    gh
     ghq
     delta
     git