summary refs log tree commit diff stats
path: root/user/settings/gaming.nix
diff options
context:
space:
mode:
Diffstat (limited to 'user/settings/gaming.nix')
-rw-r--r--user/settings/gaming.nix47
1 files changed, 8 insertions, 39 deletions
diff --git a/user/settings/gaming.nix b/user/settings/gaming.nix
index 78b35406..d6dbe42f 100644
--- a/user/settings/gaming.nix
+++ b/user/settings/gaming.nix
@@ -1,45 +1,14 @@
 { config, pkgs, ... }:
 
+let
+  unstablePkgs = import <nixos-unstable> {};
+in
 {
-  home.packages = with pkgs; [
+  home.packages = with unstablePkgs; [
     steam
-    (
-      winePackages.override {
-        pngSupport = true;
-        jpegSupport = true;
-        tiffSupport = true;
-        gettextSupport = true;
-        fontconfigSupport = true;
-        alsaSupport = true;
-        gtkSupport = true;
-        openglSupport = true;
-        tlsSupport = true;
-        gstreamerSupport = true;
-        cupsSupport = true;
-        colorManagementSupport = true;
-        dbusSupport = true;
-        mpg123Support = true;
-        openalSupport = true;
-        openclSupport = true;
-        cairoSupport = true;
-        odbcSupport = true;
-        netapiSupport = true;
-        cursesSupport = true;
-        vaSupport = true;
-        pcapSupport = true;
-        v4lSupport = true;
-        saneSupport = true;
-        gsmSupport = true;
-        gphoto2Support = true;
-        ldapSupport = true;
-        pulseaudioSupport = true;
-        udevSupport = true;
-        xineramaSupport = true;
-        xmlSupport = true;
-        vulkanSupport = true;
-        sdlSupport = true;
-      }
-    )
-    lutris
+    wineWowPackages.stable
+    # winetricks
+
+    pkgs.lutris
   ];
 }