summary refs log tree commit diff stats
path: root/user/settings/emacs.nix
diff options
context:
space:
mode:
Diffstat (limited to 'user/settings/emacs.nix')
-rw-r--r--user/settings/emacs.nix10
1 files changed, 1 insertions, 9 deletions
diff --git a/user/settings/emacs.nix b/user/settings/emacs.nix
index 4cdd4d58..2e43606c 100644
--- a/user/settings/emacs.nix
+++ b/user/settings/emacs.nix
@@ -3,8 +3,6 @@
 let
   inherit (pkgs) stdenv;
 
-  pkgsUnstable = if stdenv.isDarwin then import <nixpkgs> {} else import <nixos-unstable> {};
-
   editorScript = pkgs.writeScriptBin "edit" ''
     #!${pkgs.runtimeShell}
     if [ -z "$1" ]; then
@@ -138,18 +136,12 @@ in
       which-key
       yaml-mode
     ] ++ lib.optionals (!stdenv.isDarwin) [
-      pkgs.unstable.mu
+      pkgs.mu
     ]);
   };
   home.packages = [
     editorScript
   ];
-  nixpkgs.overlays = [
-    (self: super: {
-      emacsPackagesNgGen = pkgsUnstable.emacsPackagesNgGen;
-      emacs = pkgsUnstable.emacs;
-    })
-  ];
   home.sessionVariables = {
     EDITOR = "${editorScript}/bin/edit";
   };