summary refs log tree commit diff stats
path: root/user/settings/darwin.nix
diff options
context:
space:
mode:
Diffstat (limited to 'user/settings/darwin.nix')
-rw-r--r--user/settings/darwin.nix14
1 files changed, 13 insertions, 1 deletions
diff --git a/user/settings/darwin.nix b/user/settings/darwin.nix
index 99c71326..1ffac101 100644
--- a/user/settings/darwin.nix
+++ b/user/settings/darwin.nix
@@ -1,5 +1,6 @@
 { config
 , pkgs
+, lib
 , ...
 }: {
   nixpkgs.overlays = [
@@ -141,7 +142,18 @@
     path+=($HOME/Library/Python/3.9/bin)
   '';
   programs.ssh.extraConfig = ''
-    IdentityAgent /Users/alan/Library/Containers/com.maxgoedjen.Secretive.SecretAgent/Data/socket.ssh
+    IdentityAgent ~/.strongbox/agent.sock
+  '';
+  home.activation.linkStrongboxSSHAgentSocket = lib.hm.dag.entryAfter [ "writeBoundary" ] ''
+    if [[ ! -d ~/.strongbox ]]
+    then
+      $DRY_RUN_CMD mkdir ~/.strongbox
+    fi
+    if [[ ! -S ~/.strongbox/agent.sock ]]
+    then
+      $DRY_RUN_CMD ln -s $VERBOSE_ARG \
+        ~/Library/Group\ Containers/group.strongbox.mac.mcguill/agent.sock ~/.strongbox/agent.sock
+    fi
   '';
 
   # Use GPG from  GPGTools