summary refs log tree commit diff stats
path: root/user/nano.nix
diff options
context:
space:
mode:
Diffstat (limited to 'user/nano.nix')
-rw-r--r--user/nano.nix17
1 files changed, 17 insertions, 0 deletions
diff --git a/user/nano.nix b/user/nano.nix
new file mode 100644
index 00000000..a04b20f5
--- /dev/null
+++ b/user/nano.nix
@@ -0,0 +1,17 @@
+{ pkgs, ... }:
+{
+  imports = [
+    ./settings/base.nix
+    ./settings/development/base.nix
+    ./settings/fish.nix
+    ./settings/git.nix
+    ./settings/nix.nix
+    ./settings/nixos.nix
+    ./settings/ssh.nix
+  ];
+  home = {
+    username = "alan";
+    homeDirectory = "/home/alan";
+    stateVersion = "24.11";
+  };
+}