summary refs log tree commit diff stats
path: root/user/modules/satoshipay.nix
diff options
context:
space:
mode:
Diffstat (limited to 'user/modules/satoshipay.nix')
-rw-r--r--user/modules/satoshipay.nix19
1 files changed, 19 insertions, 0 deletions
diff --git a/user/modules/satoshipay.nix b/user/modules/satoshipay.nix
new file mode 100644
index 00000000..6feefbbb
--- /dev/null
+++ b/user/modules/satoshipay.nix
@@ -0,0 +1,19 @@
+{ config, pkgs, ... }:
+
+let
+  spGitConfig = {
+    user.email = "alan@satoshipay.io";
+  };
+in
+{
+  programs.git.includes = [
+    {
+      condition = "gitdir:~/projects/github.com/satoshipay/";
+      contents = spGitConfig;
+    }
+    {
+      condition = "gitdir:~/projects/gitlab.satoshipay.tech";
+      contents = spGitConfig;
+    }
+  ];
+}