summary refs log tree commit diff stats
path: root/user/lima.nix
diff options
context:
space:
mode:
Diffstat (limited to 'user/lima.nix')
-rw-r--r--user/lima.nix31
1 files changed, 0 insertions, 31 deletions
diff --git a/user/lima.nix b/user/lima.nix
deleted file mode 100644
index 779d5af8..00000000
--- a/user/lima.nix
+++ /dev/null
@@ -1,31 +0,0 @@
-{ config, pkgs, ... }:
-{
-  imports = [
-    ./modules/tabnine.nix
-    ./settings/base.nix
-    ./settings/development/base.nix
-    ./settings/git.nix
-    ./settings/nix.nix
-    ./settings/nixos.nix
-    ./settings/ssh.nix
-    ./settings/fish.nix
-  ];
-  home = {
-    username = "alan";
-    homeDirectory = "/home/alan.linux";
-    sessionVariables = {
-      GHQ_ROOT = "/Users/alan/projects";
-      SSH_AUTH_SOCK = "/Users/alan/.strongbox/agent.sock";
-    };
-    stateVersion = "23.11";
-  };
-  programs.ssh.extraConfig = ''
-    IdentityAgent ${config.home.sessionVariables.SSH_AUTH_SOCK}
-  '';
-  # home-manager complains when setting nix.conf otherwise
-  nix.package = pkgs.nix;
-  nix.settings = {
-    max-jobs = 4;
-    experimental-features = "nix-command flakes";
-  };
-}