summary refs log tree commit diff stats
path: root/system/settings/services/xserver.nix
diff options
context:
space:
mode:
Diffstat (limited to 'system/settings/services/xserver.nix')
-rw-r--r--system/settings/services/xserver.nix58
1 files changed, 32 insertions, 26 deletions
diff --git a/system/settings/services/xserver.nix b/system/settings/services/xserver.nix
index c78693c1..7e2a7c49 100644
--- a/system/settings/services/xserver.nix
+++ b/system/settings/services/xserver.nix
@@ -1,7 +1,11 @@
-{ config, lib, pkgs, ... }:
-
-with lib;
-{ services.xserver = {
+{
+  config,
+  lib,
+  pkgs,
+  ...
+}:
+with lib; {
+  services.xserver = {
     enable = true;
     enableCtrlAltBackspace = true;
     exportConfiguration = true;
@@ -37,9 +41,9 @@ with lib;
       };
       useEmbeddedBitmaps = !config.fonts.fontconfig.antialias;
       defaultFonts = {
-        monospace = [ "IBM Plex Mono" ];
-        sansSerif = [ "Cantarell" ];
-        serif = [ "Times New Roman" ];
+        monospace = ["IBM Plex Mono"];
+        sansSerif = ["Cantarell"];
+        serif = ["Times New Roman"];
       };
 
       localConf = ''
@@ -57,28 +61,30 @@ with lib;
         </fontconfig>
       '';
     };
-    fonts = with pkgs; [
-      gohufont
-      dina-font
-      terminus_font
+    fonts = with pkgs;
+      [
+        gohufont
+        dina-font
+        terminus_font
 
-      corefonts
+        corefonts
 
-      emacs-all-the-icons-fonts
-      font-awesome_5
-      xorg.fontmiscmisc
-      xorg.fontcursormisc
-    ] ++ lib.optionals config.fonts.fontconfig.antialias [
-      cantarell-fonts
+        emacs-all-the-icons-fonts
+        font-awesome_5
+        xorg.fontmiscmisc
+        xorg.fontcursormisc
+      ]
+      ++ lib.optionals config.fonts.fontconfig.antialias [
+        cantarell-fonts
 
-      fira
-      fira-code
-      fira-mono
-      ibm-plex
+        fira
+        fira-code
+        fira-mono
+        ibm-plex
 
-      source-code-pro
-      source-sans-pro
-      source-serif-pro
-    ];
+        source-code-pro
+        source-sans-pro
+        source-serif-pro
+      ];
   };
 }