summary refs log tree commit diff stats
path: root/system/settings/hardware/intel-gpu.nix
diff options
context:
space:
mode:
Diffstat (limited to 'system/settings/hardware/intel-gpu.nix')
-rw-r--r--system/settings/hardware/intel-gpu.nix12
1 files changed, 4 insertions, 8 deletions
diff --git a/system/settings/hardware/intel-gpu.nix b/system/settings/hardware/intel-gpu.nix
index 81fd765e..95d27cc0 100644
--- a/system/settings/hardware/intel-gpu.nix
+++ b/system/settings/hardware/intel-gpu.nix
@@ -1,13 +1,9 @@
 { config, pkgs, ... }:
 
-{ hardware.opengl.extraPackages = with pkgs; [
-    vaapiIntel
-    vaapiVdpau
-    libvdpau-va-gl
-  ];
+{
 
-  boot.earlyVconsoleSetup = true;
-  boot.initrd.kernelModules = [
-    "i915"
+  boot.kernelParams = [
+    "i915.enable_guc=2"
+    "i915.fastboot=1"
   ];
 }