summary refs log tree commit diff stats
path: root/system/settings/hardware/bare-metal.nix
diff options
context:
space:
mode:
Diffstat (limited to 'system/settings/hardware/bare-metal.nix')
-rw-r--r--system/settings/hardware/bare-metal.nix17
1 files changed, 10 insertions, 7 deletions
diff --git a/system/settings/hardware/bare-metal.nix b/system/settings/hardware/bare-metal.nix
index ce8e57e2..0b8ce6d2 100644
--- a/system/settings/hardware/bare-metal.nix
+++ b/system/settings/hardware/bare-metal.nix
@@ -1,8 +1,11 @@
-{ config, pkgs, ... }:
-
-{ environment.systemPackages = with pkgs; [
+{
+  config,
+  pkgs,
+  ...
+}: {
+  environment.systemPackages = with pkgs; [
     exfat
-		efibootmgr
+    efibootmgr
     cryptsetup
     dmidecode
     hdparm
@@ -28,7 +31,7 @@
     ACTION=="add|change", KERNEL=="sd[a-z]", ATTR{queue/rotational}=="1", ATTR{queue/scheduler}="bfq"
   '';
 
-  boot.kernelModules = [ "tcp_bbr" ];
+  boot.kernelModules = ["tcp_bbr"];
   boot.kernel.sysctl = {
     "net.core.default_qdisc" = "cake";
     "net.ipv4.tcp_allowed_congestion_control" = "bbr illinois reno lp";
@@ -44,6 +47,6 @@
   };
   boot.tmpOnTmpfs = true;
 
-  fileSystems."/".options = [ "noatime" "nodiratime" ];
-  fileSystems."/home".options = [ "noatime" "nodiratime" ];
+  fileSystems."/".options = ["noatime" "nodiratime"];
+  fileSystems."/home".options = ["noatime" "nodiratime"];
 }