summary refs log tree commit diff stats
path: root/system/settings/gaming.nix
diff options
context:
space:
mode:
Diffstat (limited to 'system/settings/gaming.nix')
-rw-r--r--system/settings/gaming.nix7
1 files changed, 5 insertions, 2 deletions
diff --git a/system/settings/gaming.nix b/system/settings/gaming.nix
index 777bd598..b00aadb7 100644
--- a/system/settings/gaming.nix
+++ b/system/settings/gaming.nix
@@ -3,6 +3,7 @@
   pkgs,
   ...
 }: {
+  security.rtkit.enable = true;
   programs.steam.enable = true;
   programs.gamemode = {
     enable = true;
@@ -19,7 +20,10 @@
   };
   fonts.fontconfig.cache32Bit = true;
   hardware.steam-hardware.enable = true;
-  hardware.opengl.driSupport32Bit = true;
+  hardware.opengl = {
+    enable = true;
+    driSupport32Bit = true;
+  };
   hardware.pulseaudio.support32Bit = true;
   services.pipewire.alsa.support32Bit = true;
   services.pipewire.config.pipewire = {
@@ -126,7 +130,6 @@
 
   services.ananicy = {
     enable = true;
-    package = pkgs.ananicy-cpp;
   };
 
   networking.firewall = {