summary refs log tree commit diff stats
path: root/system/settings/darwin.nix
diff options
context:
space:
mode:
Diffstat (limited to 'system/settings/darwin.nix')
-rw-r--r--system/settings/darwin.nix4
1 files changed, 3 insertions, 1 deletions
diff --git a/system/settings/darwin.nix b/system/settings/darwin.nix
index 62859e7e..65d6f3ee 100644
--- a/system/settings/darwin.nix
+++ b/system/settings/darwin.nix
@@ -25,7 +25,9 @@
     enable = true;
     enableCompletion = false; # Causes >2s startup time, overlaps home-manager config
     enableBashCompletion = true;
-    loginShellInit = builtins.readFile "/System/Library/Templates/Data/private/etc/zprofile";
+    loginShellInit = ''
+      source /System/Library/Templates/Data/private/etc/zprofile
+    '';
     interactiveShellInit = ''
       if [[ "$(locale LC_CTYPE)" == "UTF-8" ]]; then
         setopt COMBINING_CHARS