summary refs log tree commit diff stats
path: root/system/settings/darwin.nix
diff options
context:
space:
mode:
Diffstat (limited to 'system/settings/darwin.nix')
-rw-r--r--system/settings/darwin.nix11
1 files changed, 11 insertions, 0 deletions
diff --git a/system/settings/darwin.nix b/system/settings/darwin.nix
index 460d47bd..323b00d6 100644
--- a/system/settings/darwin.nix
+++ b/system/settings/darwin.nix
@@ -32,6 +32,17 @@
     allowUnfree = true;
   };
 
+  launchd.user.agents.lorri = lib.mkIf config.services.lorri.enable {
+    serviceConfig = {
+      RunAtLoad = lib.mkForce false;
+      Sockets = {
+        daemon = {
+          SockPathName = "${(builtins.getEnv "HOME")}/Library/Caches/com.github.target.lorri.lorri.lorri/daemon.socket";
+        };
+      };
+    };
+  };
+
   environment.launchDaemons = {
     "limit.maxfiles.plist" = {
       text = ''