summary refs log tree commit diff stats
path: root/system/prefect.nix
diff options
context:
space:
mode:
Diffstat (limited to 'system/prefect.nix')
-rw-r--r--system/prefect.nix20
1 files changed, 20 insertions, 0 deletions
diff --git a/system/prefect.nix b/system/prefect.nix
index f5d1ea5f..deaad479 100644
--- a/system/prefect.nix
+++ b/system/prefect.nix
@@ -23,6 +23,7 @@
     ./settings/hardware/keyboardio-model01.nix
     ./settings/hardware/trackball.nix
     ./settings/hardware/trezor.nix
+    ./settings/services/samba.nix
     ./settings/services/syncthing.nix
     ./settings/services/zeroconf.nix
     ./settings/user-interface.nix
@@ -130,5 +131,24 @@
   };
   systemd.services.transmission.requires = [ "mnt-data.mount" ];
 
+  services.samba = {
+    extraConfig = ''
+      hosts allow = 172.30.42. 127.0.0.1 localhost
+      hosts deny = 0.0.0.0/0
+    '';
+    shares = {
+      Music = {
+        path = "/mnt/data/Home/Music/";
+        browseable = "yes";
+        "read only" = "yes";
+        "guest ok" = "yes";
+        "create mask" = "0644";
+        "directory mask" = "0755";
+        "force user" = "alan";
+        "force group" = "users";
+      };
+    };
+  };
+
   system.stateVersion = "22.05";
 }