summary refs log tree commit diff stats
path: root/system/prefect.nix
diff options
context:
space:
mode:
Diffstat (limited to 'system/prefect.nix')
-rw-r--r--system/prefect.nix13
1 files changed, 11 insertions, 2 deletions
diff --git a/system/prefect.nix b/system/prefect.nix
index 7785e76b..6ce2fb50 100644
--- a/system/prefect.nix
+++ b/system/prefect.nix
@@ -94,8 +94,17 @@
     serviceConfig.ExecStart = "${pkgs.systemd}/bin/systemd-inhibit --mode block --what sleep --who 'ssh session '%I --why 'session still active' ${pkgs.coreutils}/bin/sleep infinity";
   };
 
-  # needed to resolve local hostname overrides
-  services.resolved.dnssec = "false";
+  systemd.network = {
+    enable = true;
+    networks."40-enp7s0" = {
+      dhcpV4Config = {
+        UseDNS = true;
+      };
+      ipv6AcceptRAConfig = {
+        UseDNS = true;
+      };
+    };
+  };
   networking = {
     useDHCP = false;
     useNetworkd = true;