summary refs log tree commit diff stats
path: root/system/prefect.nix
diff options
context:
space:
mode:
Diffstat (limited to 'system/prefect.nix')
-rw-r--r--system/prefect.nix12
1 files changed, 9 insertions, 3 deletions
diff --git a/system/prefect.nix b/system/prefect.nix
index 7c904bab..8543527c 100644
--- a/system/prefect.nix
+++ b/system/prefect.nix
@@ -3,7 +3,7 @@
 { imports = [
     ./hardware-configuration.nix
     <nixos-hardware/common/pc/ssd>
-    <nixos-hardware/common/cpu/intel>
+    <nixos-hardware/common/cpu/amd>
 
     ./settings/satoshipay.nix
     ./settings/base.nix
@@ -29,6 +29,8 @@
     ./settings/programs/tor.nix
     ./settings/programs/barrier.nix
   ];
+  hardware.cpu.amd.updateMicrocode = true;
+
   services.xserver.screenSection = ''
     Option "MetaModes" "2560x1440_120 +0+0 { ForceFullCompositionPipeline = On }"
     Option "AllowIndirectGLXProtocol" "off"
@@ -37,6 +39,11 @@
   boot.loader.timeout = 3;
   boot.loader.grub.default = 2; # Default to Windows
 
+  boot.kernelPackages = (import <nixos-unstable> { config = config.nixpkgs.config; }).linuxPackages_5_10;
+  boot.extraModulePackages = with config.boot.kernelPackages; [
+    zenpower
+  ];
+
   fileSystems."/data" = {
     label = "Data";
     fsType = "ntfs";
@@ -86,8 +93,7 @@
     '';
   };
 
-  powerManagement.enable = false;
-  powerManagement.cpuFreqGovernor = "performance";
+  powerManagement.cpuFreqGovernor = "schedutil";
   networking = {
     hostName = "prefect";
   };