summary refs log tree commit diff stats
path: root/system/prefect.nix
diff options
context:
space:
mode:
Diffstat (limited to 'system/prefect.nix')
-rw-r--r--system/prefect.nix7
1 files changed, 2 insertions, 5 deletions
diff --git a/system/prefect.nix b/system/prefect.nix
index fa57ef36..d3e1359e 100644
--- a/system/prefect.nix
+++ b/system/prefect.nix
@@ -1,13 +1,8 @@
 { config
 , pkgs
-, nixos-hardware
 , ...
 }: {
   imports = [
-    (nixos-hardware + "/common/pc/ssd")
-    (nixos-hardware + "/common/cpu/amd")
-    (nixos-hardware + "/common/cpu/amd/pstate.nix")
-
     ./settings/base.nix
     ./settings/configuration/berlin.nix
     ./settings/configuration/british-english.nix
@@ -31,6 +26,8 @@
     ./settings/gaming.nix
   ];
 
+  nixpkgs.hostPlatform = "x86_64-linux";
+
   services.xserver.screenSection = ''
     Option "MetaModes" "2560x1440_165 +0+0 { ForceCompositionPipeline=On }"
   '';