summary refs log tree commit diff stats
path: root/system/modules/services/xserver.nix
diff options
context:
space:
mode:
Diffstat (limited to 'system/modules/services/xserver.nix')
-rw-r--r--system/modules/services/xserver.nix82
1 files changed, 0 insertions, 82 deletions
diff --git a/system/modules/services/xserver.nix b/system/modules/services/xserver.nix
deleted file mode 100644
index d898f55a..00000000
--- a/system/modules/services/xserver.nix
+++ /dev/null
@@ -1,82 +0,0 @@
-{ config, pkgs, ... }:
-
-{ services.xserver = {
-    enable = true;
-    enableCtrlAltBackspace = true;
-    exportConfiguration = true;
-  };
-
-  i18n.consoleUseXkbConfig = true;
-
-  environment.systemPackages = with pkgs; [
-    xorg.xmodmap
-    xorg.xinit
-    xorg.xev
-    xorg.xdpyinfo
-    xclip
-    xfontsel
-
-    vanilla-dmz
-    capitaine-cursors
-    bibata-cursors
-
-    arc-theme
-    hicolor_icon_theme
-    paper-gtk-theme
-    paper-icon-theme
-
-    arc-icon-theme
-    tango-icon-theme
-
-    gtk-engine-murrine
-    gtk_engines
-  ];
-
-  fonts = {
-    enableFontDir = true;
-    enableDefaultFonts = false;
-    fontconfig = {
-      useEmbeddedBitmaps = true;
-      defaultFonts = {
-        monospace = [ "Liberation Mono" ];
-        sansSerif = [ "Liberation Sans" ];
-        serif = [ "Liberation Serif" ];
-      };
-      penultimate = {
-        enable = true;
-      };
-      ultimate = {
-        enable = false;
-        preset = "osx";
-      };
-    };
-    fonts = with pkgs; [
-      dina-font
-      envypn-font
-      profont
-      proggyfonts
-      terminus_font
-      terminus_font_ttf
-
-      fantasque-sans-mono
-      emacs-all-the-icons-fonts
-      fira
-      fira-code
-      fira-mono
-      go-font
-      font-awesome_5
-      ibm-plex
-      liberation_ttf
-      mononoki
-      roboto
-      roboto-mono
-      roboto-slab
-      source-code-pro
-      source-sans-pro
-      source-serif-pro
-      xorg.fontmiscmisc
-      xorg.fontcursormisc
-      xorg.fontbhlucidatypewriter100dpi
-    ];
-  };
-}