summary refs log tree commit diff stats
path: root/system/modules/hardware/synaptics.nix
diff options
context:
space:
mode:
Diffstat (limited to 'system/modules/hardware/synaptics.nix')
-rw-r--r--system/modules/hardware/synaptics.nix27
1 files changed, 27 insertions, 0 deletions
diff --git a/system/modules/hardware/synaptics.nix b/system/modules/hardware/synaptics.nix
new file mode 100644
index 00000000..9f075cce
--- /dev/null
+++ b/system/modules/hardware/synaptics.nix
@@ -0,0 +1,27 @@
+{ config, pkgs, ... }:
+
+{ services.xserver = {
+    libinput.enable = false;
+    synaptics = {
+      enable = true;
+
+      accelFactor = "0.04";
+
+      minSpeed = "0.3";
+      maxSpeed = "0.6";
+
+      palmDetect = true;
+      palmMinWidth = 5;
+      palmMinZ = 20;
+
+      twoFingerScroll = true;
+      vertTwoFingerScroll = true;
+      horizTwoFingerScroll = true;
+      additionalOptions = ''
+        Option "RBCornerButton" "3"
+        Option "VertScrollDelta" "-111"
+        Option "HorizScrollDelta" "-111"
+      '';
+    };
+  };
+}