summary refs log tree commit diff stats
path: root/system/modules/hardware/printing.nix
diff options
context:
space:
mode:
Diffstat (limited to 'system/modules/hardware/printing.nix')
-rw-r--r--system/modules/hardware/printing.nix19
1 files changed, 0 insertions, 19 deletions
diff --git a/system/modules/hardware/printing.nix b/system/modules/hardware/printing.nix
deleted file mode 100644
index 96d3a959..00000000
--- a/system/modules/hardware/printing.nix
+++ /dev/null
@@ -1,19 +0,0 @@
-{ config, pkgs, lib, ... }:
-
-{ services.printing.enable = true;
-  systemd.services.cups.wantedBy = lib.mkForce [];
-  systemd.sockets.cups.wantedBy = [ "sockets.target" ];
-  systemd.services.cups-browsed.wantedBy = lib.mkForce [];
-
-  systemd.timers.cups-browsed = {
-    description = "Delayed startup of CUPS Remote Printer Discovery";
-    wantedBy = [ "timers.target" ];
-    timerConfig = {
-      OnActiveSec = "2 min";
-    };
-  };
-
-  imports = [
-    ../services/zeroconf.nix
-  ];
-}