summary refs log tree commit diff stats
path: root/system/modules/hardware/intel-gpu.nix
diff options
context:
space:
mode:
Diffstat (limited to 'system/modules/hardware/intel-gpu.nix')
-rw-r--r--system/modules/hardware/intel-gpu.nix15
1 files changed, 15 insertions, 0 deletions
diff --git a/system/modules/hardware/intel-gpu.nix b/system/modules/hardware/intel-gpu.nix
new file mode 100644
index 00000000..fc6b6fa3
--- /dev/null
+++ b/system/modules/hardware/intel-gpu.nix
@@ -0,0 +1,15 @@
+{ config, pkgs, ... }:
+
+{ hardware.opengl.extraPackages = with pkgs; [
+    vaapiIntel
+    vaapiVdpau
+    libvdpau-va-gl
+  ];
+
+  services.xserver.videoDrivers = [ "intel" "modesetting" ];
+
+  boot.earlyVconsoleSetup = true;
+  boot.initrd.kernelModules = [
+    "i915"
+  ];
+}