summary refs log tree commit diff stats
path: root/system/modules/hardware/adb.nix
diff options
context:
space:
mode:
Diffstat (limited to 'system/modules/hardware/adb.nix')
-rw-r--r--system/modules/hardware/adb.nix9
1 files changed, 9 insertions, 0 deletions
diff --git a/system/modules/hardware/adb.nix b/system/modules/hardware/adb.nix
new file mode 100644
index 00000000..8b511f55
--- /dev/null
+++ b/system/modules/hardware/adb.nix
@@ -0,0 +1,9 @@
+{ config, pkgs, ... }:
+
+{ programs.adb.enable = true;
+  users.groups.adbusers = {};
+
+  services.udev = {
+   packages = [ pkgs.android-udev-rules ];
+  };
+}