summary refs log tree commit diff stats
path: root/system/modules/darwin/kresd.nix
diff options
context:
space:
mode:
Diffstat (limited to 'system/modules/darwin/kresd.nix')
-rw-r--r--system/modules/darwin/kresd.nix45
1 files changed, 45 insertions, 0 deletions
diff --git a/system/modules/darwin/kresd.nix b/system/modules/darwin/kresd.nix
new file mode 100644
index 00000000..6bce8af1
--- /dev/null
+++ b/system/modules/darwin/kresd.nix
@@ -0,0 +1,45 @@
+{ config, lib, pkgs, ... }:
+
+with lib;
+
+let
+  cfg = config.services.kresd;
+  package = pkgs.knot-resolver;
+
+  configFile = pkgs.writeText "kresd.conf" cfg.extraConfig;
+in
+{
+  options = {
+    services.kresd.enable = mkOption {
+      type = types.bool;
+      default = false;
+      description = "Whether to enable knot-resolver daemon.";
+    };
+
+    services.kresd.extraConfig = mkOption {
+      type = types.lines;
+      default = "";
+      description = ''
+        Extra configuration to be added to the generated configuration file.
+      '';
+    };
+  };
+
+  config = mkIf cfg.enable {
+    launchd.daemons.kresd = {
+      command = "${package}/bin/kresd -c ${configFile}";
+
+      serviceConfig = {
+        ProcessType = "Interactive";
+        # Sockets = {
+        #   Listeners = {
+        #     SockServiceName = "dns";
+        #     SockFamily = "IPv4";
+        #   };
+        # };
+      };
+    };
+
+    environment.systemPackages = [ package ];
+  };
+}