summary refs log tree commit diff stats
path: root/system/modules/configuration/nix.nix
diff options
context:
space:
mode:
Diffstat (limited to 'system/modules/configuration/nix.nix')
-rw-r--r--system/modules/configuration/nix.nix29
1 files changed, 0 insertions, 29 deletions
diff --git a/system/modules/configuration/nix.nix b/system/modules/configuration/nix.nix
deleted file mode 100644
index d254de0e..00000000
--- a/system/modules/configuration/nix.nix
+++ /dev/null
@@ -1,29 +0,0 @@
-{ config, pkgs, ... }:
-
-{ nix = {
-    buildCores = 0;
-
-    daemonNiceLevel = 19;
-    daemonIONiceLevel = 7;
-
-    autoOptimiseStore = true;
-    gc = {
-      automatic = true;
-      options = "--delete-older-than 14d";
-    };
-  };
-
-  environment.systemPackages = with pkgs; [
-    cachix
-  ];
-
-  system.autoUpgrade = {
-    enable = true;
-    flags = [ "--max-jobs" "1" ];
-  };
-  systemd.services.nixos-upgrade = {
-    script = pkgs.lib.mkForce ''
-      ${config.system.build.nixos-rebuild}/bin/nixos-rebuild boot --no-build-output --upgrade ${toString config.system.autoUpgrade.flags}
-    '';
-  };
-}