summary refs log tree commit diff stats
path: root/system/mba.nix
diff options
context:
space:
mode:
Diffstat (limited to 'system/mba.nix')
-rw-r--r--system/mba.nix25
1 files changed, 12 insertions, 13 deletions
diff --git a/system/mba.nix b/system/mba.nix
index 6ab2300e..4989c3b5 100644
--- a/system/mba.nix
+++ b/system/mba.nix
@@ -26,19 +26,18 @@
     auto-optimise-store = false; # https://github.com/NixOS/nix/issues/7273
   };
 
-  nix.buildMachines = [
-    {
-      hostName = "lima-nixos";
-      system = "aarch64-linux";
-      sshUser = "nix-remote";
-      sshKey = "/var/root/.ssh/nix-remote";
-      protocol = "ssh-ng";
-      maxJobs = 4;
-      supportedFeatures = [ "nixos-test" "benchmark" "big-parallel" "kvm" ];
-      mandatoryFeatures = [ ];
-    }
-  ];
-  nix.distributedBuilds = true;
+  nix.linux-builder = {
+    maxJobs = 4;
+    config = {
+      virtualisation = {
+        darwin-builder = {
+          diskSize = 60 * 1024;
+          memorySize = 8 * 1024;
+        };
+        cores = 4;
+      };
+    };
+  };
 }
 # vim: sw=2 sts=2 expandtab autoindent smarttab