summary refs log tree commit diff stats
path: root/system/cachix.nix
diff options
context:
space:
mode:
Diffstat (limited to 'system/cachix.nix')
-rw-r--r--system/cachix.nix14
1 files changed, 14 insertions, 0 deletions
diff --git a/system/cachix.nix b/system/cachix.nix
new file mode 100644
index 00000000..cce90a32
--- /dev/null
+++ b/system/cachix.nix
@@ -0,0 +1,14 @@
+
+# WARN: this file will get overwritten by $ cachix use <name>
+{ pkgs, lib, ... }:
+
+let
+  folder = ./cachix;
+  toImport = name: value: folder + ("/" + name);
+  filterCaches = key: value: value == "regular" && lib.hasSuffix ".nix" key;
+  imports = lib.mapAttrsToList toImport (lib.filterAttrs filterCaches (builtins.readDir folder));
+in {
+  inherit imports;
+  nix.binaryCaches = ["https://cache.nixos.org/"];
+}
+    
\ No newline at end of file