summary refs log tree commit diff stats
path: root/shell.nix
diff options
context:
space:
mode:
Diffstat (limited to 'shell.nix')
-rw-r--r--shell.nix19
1 files changed, 3 insertions, 16 deletions
diff --git a/shell.nix b/shell.nix
index d1270312..f41153fc 100644
--- a/shell.nix
+++ b/shell.nix
@@ -1,19 +1,7 @@
 let
-  sources = import ./npins;
+  inherit (import ./sources.nix) nixPath sources;
 
-  nixpkgs = sources.nixpkgs;
-  pkgs = import nixpkgs { };
-  inherit (pkgs) lib;
-  # lib = import ./lib { inherit pkgs; };
-  inherit (import ./lib { inherit pkgs; }) mkNixPath fromSources;
-
-  nixPath = builtins.concatStringsSep ":" (mkNixPath
-    ({
-      personal = ./packages;
-      nixpkgs-overlays = ./overlays;
-      private = ./private;
-    } // (fromSources sources))
-  );
+  pkgs = import sources.nixpkgs { };
 in
 pkgs.mkShell
 {
@@ -27,7 +15,6 @@ pkgs.mkShell
   ];
 
   shellHook = ''
-    export NIX_PATH="${nixPath}";
+    export NIX_PATH="${builtins.concatStringsSep ":"nixPath}";
   '';
-
 }