summary refs log tree commit diff stats
path: root/flake.nix
diff options
context:
space:
mode:
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix9
1 files changed, 2 insertions, 7 deletions
diff --git a/flake.nix b/flake.nix
index e61f528f..5333f1a2 100644
--- a/flake.nix
+++ b/flake.nix
@@ -162,17 +162,12 @@
         ];
       };
 
-      checks = builtins.mapAttrs
-        (system: deployLib:
-          deployLib.deployChecks self.deploy)
-        deploy-rs.lib;
-
       deploy = {
-        remoteBuild = true;
-        interactiveSudo = true;
         nodes.linde = {
           hostname = "linde";
           profiles.system = {
+            user = "root";
+            sshUser = "root";
             path = deploy-rs.lib.${utils.lib.system.aarch64-linux}.activate.nixos
               self.nixosConfigurations.linde;
           };