summary refs log tree commit diff stats
path: root/flake.nix
diff options
context:
space:
mode:
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix11
1 files changed, 11 insertions, 0 deletions
diff --git a/flake.nix b/flake.nix
index 8dad9fa1..7f6a2def 100644
--- a/flake.nix
+++ b/flake.nix
@@ -9,6 +9,7 @@
     darwin.inputs.nixpkgs.follows = "nixpkgs";
     home-manager.url = "github:nix-community/home-manager";
     home-manager.inputs.nixpkgs.follows = "nixpkgs";
+    nh-darwin.url = "github:ToyVo/nh_darwin";
     secrets = {
       flake = false;
     };
@@ -38,6 +39,7 @@
     , nixos-hardware
     , home-manager
     , darwin
+    , nh-darwin
     , nix-index-database
     , secrets
     , agenix
@@ -116,6 +118,7 @@
         specialArgs = { inherit inputs; };
         modules = [
           ./system/marvin.nix
+          nh-darwin.nixDarwinModules.prebuiltin
           personal.darwinModules.caddy
         ];
       };
@@ -154,4 +157,12 @@
         ];
       };
     };
+  nixConfig = {
+    extra-substituters = [
+      "https://toyvo.cachix.org"
+    ];
+    extra-trusted-public-keys = [
+      "toyvo.cachix.org-1:s++CG1te6YaS9mjICre0Ybbya2o/S9fZIyDNGiD4UXs="
+    ];
+  };
 }