about summary refs log tree commit diff stats
path: root/pkgs/vanity-imports/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'pkgs/vanity-imports/default.nix')
-rw-r--r--pkgs/vanity-imports/default.nix28
1 files changed, 28 insertions, 0 deletions
diff --git a/pkgs/vanity-imports/default.nix b/pkgs/vanity-imports/default.nix
new file mode 100644
index 0000000..4c20919
--- /dev/null
+++ b/pkgs/vanity-imports/default.nix
@@ -0,0 +1,28 @@
+{ lib
+, buildGoModule
+, fetchFromGitHub
+}:
+
+buildGoModule rec {
+  pname = "vanity-imports";
+  version = "0.0.12";
+
+  src = fetchFromGitHub {
+    owner = "mlcdf";
+    repo = "vanity-imports";
+    rev = "v${version}";
+    hash = "sha256-4JoJL079hBkwWVvOTRbCM1WZhM7hPlKQ+HEAUr7fWP8=";
+  };
+
+  vendorHash = "sha256-w0LaXevbGm1xpHvKxxyubHCOVRN712UzLyOd+hVikKg=";
+
+  ldflags = [ "-s" "-w" ];
+
+  meta = with lib; {
+    description = "Use a custom domain in your Go import path";
+    homepage = "https://github.com/mlcdf/vanity-imports";
+    license = licenses.mit;
+    maintainers = with maintainers; [ alanpearce ];
+    mainProgram = "vanity-imports";
+  };
+}