about summary refs log tree commit diff stats
diff options
context:
space:
mode:
-rw-r--r--flake.nix23
1 files changed, 18 insertions, 5 deletions
diff --git a/flake.nix b/flake.nix
index 281bc6c..484f924 100644
--- a/flake.nix
+++ b/flake.nix
@@ -15,12 +15,25 @@
       forAllSystems = f: nixpkgs.lib.genAttrs systems (system: f system);
     in
     {
-      legacyPackages = forAllSystems (system: import ./default.nix {
+      legacyPackages = forAllSystems (system: (import ./default.nix {
         pkgs = import nixpkgs { inherit system; };
-      });
+      }));
       packages = forAllSystems (system:
-        nixpkgs.lib.filterAttrs
-          (_: v: nixpkgs.lib.isDerivation v)
-          self.legacyPackages.${system});
+        let
+          pkgs = import nixpkgs { inherit system; };
+
+          lpkgs = nixpkgs.lib.filterAttrs
+            (_: v: nixpkgs.lib.isDerivation v)
+            self.legacyPackages.${system};
+
+          all = pkgs.symlinkJoin {
+            name = "all";
+            paths = builtins.attrValues lpkgs;
+          };
+        in
+        (lpkgs // {
+          inherit all;
+          default = all;
+        }));
     };
 }