summary refs log tree commit diff stats
path: root/modules/shell.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/shell.nix')
-rw-r--r--modules/shell.nix29
1 files changed, 0 insertions, 29 deletions
diff --git a/modules/shell.nix b/modules/shell.nix
deleted file mode 100644
index 3ea43ad..0000000
--- a/modules/shell.nix
+++ /dev/null
@@ -1,29 +0,0 @@
-{ config, pkgs, ... }:
-
-{ programs.zsh = {
-    enable = true;
-    promptInit = "";
-  };
-  programs.bash.enableCompletion = true;
-  programs.xonsh = {
-    enable = true;
-  };
-
-  environment.systemPackages = with pkgs; [
-    vim
-    pv
-    file
-    htop
-    lsof
-    iftop
-    iotop
-    nmap
-    netperf
-    moreutils
-    psmisc
-    tree
-    zip
-    unzip
-    telnet
-  ];
-}