summary refs log tree commit diff stats
path: root/modules/services/zeroconf.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/services/zeroconf.nix')
-rw-r--r--modules/services/zeroconf.nix11
1 files changed, 10 insertions, 1 deletions
diff --git a/modules/services/zeroconf.nix b/modules/services/zeroconf.nix
index aa4b47e..0b428c5 100644
--- a/modules/services/zeroconf.nix
+++ b/modules/services/zeroconf.nix
@@ -1,7 +1,16 @@
-{ config, pkgs, ... }:
+{ config, pkgs, lib, ... }:
 
 { services.avahi = {
     enable = true;
     nssmdns = true;
+    ipv6 = true;
+  };
+  systemd.services.avahi-daemon.wantedBy = lib.mkForce [];
+  systemd.timers.avahi-daemon = {
+    description = "Delayed startup of Avahi";
+    wantedBy = [ "timers.target" ];
+    timerConfig = {
+      OnActiveSec = "1 min";
+    };
   };
 }