summary refs log tree commit diff stats
path: root/modules/nix.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/nix.nix')
-rw-r--r--modules/nix.nix25
1 files changed, 0 insertions, 25 deletions
diff --git a/modules/nix.nix b/modules/nix.nix
deleted file mode 100644
index 504942e..0000000
--- a/modules/nix.nix
+++ /dev/null
@@ -1,25 +0,0 @@
-{ config, pkgs, ... }:
-
-{ nix = {
-    buildCores = 0;
-
-    daemonNiceLevel = 10;
-    daemonIONiceLevel = 4;
-
-    autoOptimiseStore = true;
-    gc = {
-      automatic = true;
-      options = "--delete-older-than 30d";
-    };
-  };
-
-  system.autoUpgrade = {
-    enable = true;
-  };
-  systemd.services.nixos-upgrade = {
-    environment.NIXPKGS_ALLOW_UNFREE = "1";
-    script = ''
-      ${config.system.build.nixos-rebuild}/bin/nixos-rebuild boot ${toString config.system.autoUpgrade.flags}
-    '';
-  };
-}