summary refs log tree commit diff stats
path: root/modules/hardware/nitrokey.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/hardware/nitrokey.nix')
-rw-r--r--modules/hardware/nitrokey.nix26
1 files changed, 26 insertions, 0 deletions
diff --git a/modules/hardware/nitrokey.nix b/modules/hardware/nitrokey.nix
new file mode 100644
index 0000000..ac85e35
--- /dev/null
+++ b/modules/hardware/nitrokey.nix
@@ -0,0 +1,26 @@
+{ config, nixpkgs, ... }:
+
+let
+  pkgsUnstable = import <nixos-unstable> {};
+  # pkgsUnstable = pkgs;
+in
+{ programs.ssh.startAgent = false;
+
+  services.pcscd.enable = true;
+
+  services.tor = {
+    enable = true;
+    client = {
+      enable = true;
+      socksListenAddress = "9050 IPv6Traffic";
+    };
+    torsocks = {
+      enable = true;
+    };
+  };
+
+  environment.systemPackages = [
+    pkgsUnstable.gnupg
+    pkgsUnstable.nitrokey-app
+  ];
+}