summary refs log tree commit diff stats
path: root/modules/hardware/nitrokey.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/hardware/nitrokey.nix')
-rw-r--r--modules/hardware/nitrokey.nix10
1 files changed, 9 insertions, 1 deletions
diff --git a/modules/hardware/nitrokey.nix b/modules/hardware/nitrokey.nix
index ec25d8e..22e9d76 100644
--- a/modules/hardware/nitrokey.nix
+++ b/modules/hardware/nitrokey.nix
@@ -1,4 +1,4 @@
-{ config, pkgs, ... }:
+{ config, pkgs, lib, ... }:
 
 { programs.ssh.startAgent = false;
 
@@ -26,6 +26,14 @@
       enable = true;
     };
   };
+  systemd.services.tor.wantedBy = lib.mkForce [];
+  systemd.timers.tor = {
+    description = "Delayed startup of Tor";
+    wantedBy = [ "timers.target" ];
+    timerConfig = {
+      OnActiveSec = "1 min";
+    };
+  };
 
   environment.systemPackages = with pkgs; [
     gnupg