about summary refs log tree commit diff stats
path: root/flake.nix
diff options
context:
space:
mode:
authorAlan Pearce2024-04-21 18:46:12 +0200
committerAlan Pearce2024-04-21 20:48:34 +0200
commitf334fc8d4caed2663ef3008f43d2f2fc48e3eaa9 (patch)
treef0942e920e8a2e4161f0a8dad3a15b9a7aff6d08 /flake.nix
parent2c6722bd18097cdcbed23d526ace0b751caf324a (diff)
downloadwebsite-f334fc8d4caed2663ef3008f43d2f2fc48e3eaa9.tar.lz
website-f334fc8d4caed2663ef3008f43d2f2fc48e3eaa9.tar.zst
website-f334fc8d4caed2663ef3008f43d2f2fc48e3eaa9.zip
use justfile for scripting
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix20
1 files changed, 7 insertions, 13 deletions
diff --git a/flake.nix b/flake.nix
index 5416016..78fe189 100644
--- a/flake.nix
+++ b/flake.nix
@@ -24,18 +24,17 @@
           packages = import ./nix/default.nix {
             inherit pkgs self;
           };
+          commonShellPackages = with pkgs; [
+            just
+            skopeo
+            flyctl
+          ];
         in
         {
           inherit packages;
           devShells = {
             ci = pkgs.mkShell {
-              packages = with pkgs; [
-                skopeo
-                flyctl
-              ]
-              ++ (import ./nix/scripts.nix {
-                inherit pkgs;
-              });
+              packages = commonShellPackages;
             };
             default = pkgs.mkShell {
               inputsFrom = [ packages.builder ];
@@ -45,13 +44,8 @@
                 go-tools
                 gomod2nix.packages.${system}.default
                 gci
-                skopeo
                 netlify-cli
-                flyctl
-              ]
-              ++ (import ./nix/scripts.nix {
-                inherit pkgs;
-              });
+              ] ++ commonShellPackages;
             };
           };
         });