about summary refs log tree commit diff stats
path: root/flake.nix
diff options
context:
space:
mode:
authorAlan Pearce2024-04-11 19:53:07 +0200
committerAlan Pearce2024-04-11 19:53:07 +0200
commite2241b8c0d1a0e5bd48d27f6ac98b3a54143da4a (patch)
tree7dc79b67d8bb2de7802c992236b14e8688e736d0 /flake.nix
parent8141685a940a33873ae6684a3aa07809c515dfc8 (diff)
downloadwebsite-e2241b8c0d1a0e5bd48d27f6ac98b3a54143da4a.tar.lz
website-e2241b8c0d1a0e5bd48d27f6ac98b3a54143da4a.tar.zst
website-e2241b8c0d1a0e5bd48d27f6ac98b3a54143da4a.zip
Simplify flake
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix24
1 files changed, 2 insertions, 22 deletions
diff --git a/flake.nix b/flake.nix
index dec5e4d..67bcc1f 100644
--- a/flake.nix
+++ b/flake.nix
@@ -1,14 +1,13 @@
 {
   description = "My website, alanpearce.eu";
   inputs.nixpkgs.url = "github:NixOS/nixpkgs/nixpkgs-unstable";
-  inputs.flockenzeit.url = "github:balsoft/Flockenzeit";
   inputs.flake-utils.url = "github:numtide/flake-utils";
   inputs.flake-compat = {
     url = "github:edolstra/flake-compat";
     flake = false;
   };
 
-  outputs = { self, nixpkgs, flockenzeit, flake-utils, ... }:
+  outputs = { nixpkgs, flake-utils, ... }:
     flake-utils.lib.eachDefaultSystem
       (system:
         let
@@ -23,31 +22,12 @@
           ];
         in
         rec {
-          packages = {
-            default = pkgs.stdenv.mkDerivation {
-              name = "alanpearce.eu";
-              src = self;
-
-              enableParallelBuilding = true;
-              makeFlags = [ "PREFIX=$(out)/public" ];
-
-              inherit nativeBuildInputs;
-
-              dontFixup = true;
-            };
-            docker = import ./docker.nix {
-              inherit self pkgs flockenzeit;
-              website = packages.default;
-            };
-          };
           devShells = {
             default = pkgs.mkShell {
               packages = with pkgs; [
                 bun
                 flyctl
-              ] ++ nativeBuildInputs ++ (with pkgs.nodePackages; [
-                prettier
-              ]);
+              ] ++ nativeBuildInputs;
             };
           };
         });