about summary refs log tree commit diff stats
path: root/flake.nix
diff options
context:
space:
mode:
authorAlan Pearce2024-04-20 18:29:18 +0200
committerAlan Pearce2024-04-20 18:29:18 +0200
commitcc2245f991ca0474e3d4db9fa213be4aa8ccccb7 (patch)
tree81dff8c64a1f1c5c81e6fe8a19e4172d6e77d930 /flake.nix
parent3da735c4e72f8de390e5f4f0df63476cac43b6b1 (diff)
downloadwebsite-cc2245f991ca0474e3d4db9fa213be4aa8ccccb7.tar.lz
website-cc2245f991ca0474e3d4db9fa213be4aa8ccccb7.tar.zst
website-cc2245f991ca0474e3d4db9fa213be4aa8ccccb7.zip
Use gitlab CI
commit 3bca937c9ff91852269a828de0c778db7d1423df
Author: Alan Pearce <alan@alanpearce.eu>
Date:   Sat Apr 20 01:14:26 2024 +0200

    create gitlab CI configuration

commit ee9eeab17ac88f4020d857dcceb458c66418e2f6
Author: Alan Pearce <alan@alanpearce.eu>
Date:   Sat Apr 20 16:07:01 2024 +0200

    make helpers for both building and streaming docker images

commit d8340ec8ff3e3f9c51b55e95e27e518330435b7c
Author: Alan Pearce <alan@alanpearce.eu>
Date:   Sat Apr 20 00:20:34 2024 +0200

    use long git hashes for docker tags
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix10
1 files changed, 10 insertions, 0 deletions
diff --git a/flake.nix b/flake.nix
index 2d15ecb..5416016 100644
--- a/flake.nix
+++ b/flake.nix
@@ -28,6 +28,15 @@
         {
           inherit packages;
           devShells = {
+            ci = pkgs.mkShell {
+              packages = with pkgs; [
+                skopeo
+                flyctl
+              ]
+              ++ (import ./nix/scripts.nix {
+                inherit pkgs;
+              });
+            };
             default = pkgs.mkShell {
               inputsFrom = [ packages.builder ];
               packages = with pkgs; [
@@ -36,6 +45,7 @@
                 go-tools
                 gomod2nix.packages.${system}.default
                 gci
+                skopeo
                 netlify-cli
                 flyctl
               ]