about summary refs log tree commit diff stats
path: root/flake.nix
diff options
context:
space:
mode:
authorAlan Pearce2023-04-12 17:50:32 +0200
committerAlan Pearce2023-04-12 17:51:38 +0200
commit666ffe8543fc6ef86be384c7f652d80c41935996 (patch)
tree3c5e0dcef0849cbe41ef82dfdb027303fbd5c0fb /flake.nix
parentd369605691337a2313a495ffc8db204653177f64 (diff)
downloadwebsite-666ffe8543fc6ef86be384c7f652d80c41935996.tar.lz
website-666ffe8543fc6ef86be384c7f652d80c41935996.tar.zst
website-666ffe8543fc6ef86be384c7f652d80c41935996.zip
Use flakes and `nix develop`
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix20
1 files changed, 20 insertions, 0 deletions
diff --git a/flake.nix b/flake.nix
new file mode 100644
index 0000000..8f31cfd
--- /dev/null
+++ b/flake.nix
@@ -0,0 +1,20 @@
+{
+  description = "My website, alanpearce.eu";
+  inputs.nixpkgs.url = "github:NixOS/nixpkgs/nixpkgs-unstable";
+  inputs.flake-utils.url = "github:numtide/flake-utils";
+
+  outputs = { self, nixpkgs, flake-utils }:
+    flake-utils.lib.eachDefaultSystem (system:
+      let
+        pkgs = nixpkgs.legacyPackages.${system};
+      in
+      {
+        devShells.default = pkgs.mkShell {
+          packages = with pkgs; [
+            gnugrep
+            git
+            zola
+          ];
+        };
+      });
+}