about summary refs log tree commit diff stats
path: root/flake.nix
diff options
context:
space:
mode:
authorAlan Pearce2024-04-14 20:11:14 +0200
committerAlan Pearce2024-04-16 18:10:11 +0200
commit4536e9e5dd826eb0e69c930312ba8f66e9c16175 (patch)
treec217312bd2c89067828fd62216295a20c01c9a91 /flake.nix
parentebb96f1a7f9828119bced5e562798a776f5849d4 (diff)
downloadwebsite-4536e9e5dd826eb0e69c930312ba8f66e9c16175.tar.lz
website-4536e9e5dd826eb0e69c930312ba8f66e9c16175.tar.zst
website-4536e9e5dd826eb0e69c930312ba8f66e9c16175.zip
wip: read posts
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix20
1 files changed, 15 insertions, 5 deletions
diff --git a/flake.nix b/flake.nix
index 67bcc1f..2faa85b 100644
--- a/flake.nix
+++ b/flake.nix
@@ -1,14 +1,19 @@
 {
   description = "My website, alanpearce.eu";
   inputs.nixpkgs.url = "github:NixOS/nixpkgs/nixpkgs-unstable";
-  inputs.flake-utils.url = "github:numtide/flake-utils";
-  inputs.flake-compat = {
+  inputs.utils.url = "github:numtide/flake-utils";
+  inputs.compat = {
     url = "github:edolstra/flake-compat";
     flake = false;
   };
+  inputs.gomod2nix = {
+    url = "github:tweag/gomod2nix";
+    inputs.nixpkgs.follows = "nixpkgs";
+    inputs.flake-utils.follows = "utils";
+  };
 
-  outputs = { nixpkgs, flake-utils, ... }:
-    flake-utils.lib.eachDefaultSystem
+  outputs = { nixpkgs, utils, gomod2nix, ... }:
+    utils.lib.eachDefaultSystem
       (system:
         let
           pkgs = nixpkgs.legacyPackages.${system};
@@ -19,13 +24,18 @@
             gzip
             zstd
             git
+            go
           ];
         in
         rec {
           devShells = {
             default = pkgs.mkShell {
               packages = with pkgs; [
-                bun
+                gopls
+                gotools
+                go-tools
+                gomod2nix.packages.${system}.default
+                gci
                 flyctl
               ] ++ nativeBuildInputs;
             };