about summary refs log tree commit diff stats
path: root/flake.nix
diff options
context:
space:
mode:
authorAlan Pearce2024-04-19 14:53:51 +0200
committerAlan Pearce2024-04-19 14:54:05 +0200
commit0fc79f324d54cc7a45c0ad0ffa9c75cd716e0126 (patch)
tree135793af7cdd7162454d8dd1a4a8e6ad553193d4 /flake.nix
parent8dd538daadc55a935e6dc205d9b2559830818c07 (diff)
downloadwebsite-0fc79f324d54cc7a45c0ad0ffa9c75cd716e0126.tar.lz
website-0fc79f324d54cc7a45c0ad0ffa9c75cd716e0126.tar.zst
website-0fc79f324d54cc7a45c0ad0ffa9c75cd716e0126.zip
server: configure with flags/envvars instead of toml
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix4
1 files changed, 2 insertions, 2 deletions
diff --git a/flake.nix b/flake.nix
index cd1e86d..4d78ce1 100644
--- a/flake.nix
+++ b/flake.nix
@@ -34,10 +34,10 @@
                 gci
                 flyctl
                 (writeShellScriptBin "watch-builder" ''
-                  ${pkgs.watchexec}/bin/watchexec -r -w flake.nix --shell fish 'direnv exec . watchexec -i server.go -i public -r go run ./cmd/build'
+                  ${pkgs.watchexec}/bin/watchexec -r -w flake.nix --shell fish "direnv exec . watchexec -i server.go -i public -r go run ./cmd/build $@"
                 '')
                 (writeShellScriptBin "watch-server" ''
-                  ${pkgs.watchexec}/bin/watchexec -r -w flake.nix --shell fish 'direnv exec . watchexec -r go run ./server.go'
+                  ${pkgs.watchexec}/bin/watchexec -r -w flake.nix --shell fish "direnv exec . watchexec -r go run ./server.go $@"
                 '')
                 (writeShellScriptBin "check-licenses" ''
                   ${pkgs.go-licenses}/bin/go-licenses check --include_tests ./... --disallowed_types=restricted,forbidden