{ config
, pkgs
, ...
}:
let
  name = "Alan Pearce";
  email = "alan@alanpearce.eu";
in
{
  programs.git = {
    enable = true;
    userName = name;
    userEmail = email;
    delta = {
      enable = false;
      options = {
        navigate = true;
        light = true;
      };
    };
    difftastic = {
      enable = true;
    };
    extraConfig = {
      init = {
        defaultBranch = "main";
      };
      apply = {
        whitespace = "fix";
      };
      advice = {
        addEmptyPathspec = false;
        detachedHead = false;
        mergeConflict = false;
      };
      ghq = {
        root = "${config.home.homeDirectory}/projects";
        user = "alanpearce";
      };
      core = {
        commitGraph = true;
        autocrlf = "input";
        safecrlf = true;
      };
      commit = {
        verbose = true;
      };
      pull = {
        rebase = true;
        ff = "only";
      };
      fetch = {
        prune = true;
        pruneTags = true;
      };
      push = {
        default = "current";
        autoSetupRemote = true;
        followTags = true;
      };
      rebase = {
        autostash = true;
        autosquash = true;
        updateRefs = true;
      };
      rerere = {
        enabled = true;
        autoupdate = true;
      };
      merge = {
        conflictStyle = "zdiff3";
      };
      "merge.mergiraf" = {
        name = "mergiraf";
        driver = "${pkgs.mergiraf}/bin/mergiraf merge --git %O %A %B -s %S -x %X -y %Y -p %P -l %L";
      };
      diff = {
        algorithm = "histogram";
        colorMoved = "plain";
        colorMovedWS = "allow-indentation-change";
        mnemonicPrefix = true;
        renames = true;
      };
      format = {
        pretty = "fuller";
      };
      grep = {
        patternType = "perl";
      };
      remote = {
        autoSetupMerge = true;
      };
      branch = {
        sort = "committerdate";
      };
      log = {
        date = "iso-local";
      };
      tag = {
        sort = "version:refname";
      };
      "branch.master" = {
        rebase = false;
      };
      "branch.main" = {
        rebase = false;
      };
      "url.git@github.com:".insteadOf = "https://github.com/";
    };
    signing = {
      key = "0xCD4BEB92A8D46583";
    };
    aliases = {
      authors = "shortlog -s -n";
      mup = "merge FETCH_HEAD";
      rup = "rebase FETCH_HEAD";
      ls = "ls-files";
      st = "status -sb";
      ci = "commit";
      br = "branch";
      co = "checkout";
      sw = "switch";
      rs = "restore";
      lasttag = "!sh -c 'git tag --sort=version:refname | grep \"^v\\\\?[0-9]\" | tail -n1'";
      pending = "!sh -c 'git log --oneline --grep=\"#\" ...$(git lasttag)'";
      lg = "log --pretty=format:'%Cred%h%Creset -%Creset %s %Cgreen(%cr) %C(bold blue)<%an> %Cred%d%Creset'";
      ignored = "ls-files --others -i --exclude-standard";
      clear = "clear-soft";
      clear-hard = "!git-clear-hard";
      dlog = "-c diff.external=difft log --ext-diff";
      dshow = "-c diff.external=difft show --ext-diff";
      ddiff = "-c diff.external=difft diff";
      dl = "dlog";
      ds = "dshow";
      dt = "ddiff";
    };
    ignores = [
      ".DS_Store"
      "*_flymake.*"
      "*~"
      "\#*\#"
      ".\#*"
      ".tabnine_root"
    ];
  };
  programs.gh = {
    enable = true;
    settings = {
      git_protocol = "ssh";
      aliases = {
        fork = "repo fork --remote --remote-name alanpearce --default-branch-only";
      };
    };
  };
  programs.jujutsu = {
    enable = true;
    settings = {
      user = {
        inherit name email;
      };
      ui = {
        "diff.tool" = [ "${pkgs.difftastic}/bin/difft" "--color=always" "$left" "$right" ];
      };
    };
  };
  xdg.configFile."git/attributes" = {
    source = (pkgs.runCommandLocal "mergiraf-gitattributes" { } ''
      ${pkgs.mergiraf}/bin/mergiraf languages --gitattributes >> $out
    '');
  };
  home.packages = with pkgs; [
    git-extras # delete-merged-branches and friends
    git-worktree-switcher
    ghq
    # reduce these on server
    mergiraf
    gitui
    gitstatus
    hut # sourcehut tools
  ];
}