{ config
, pkgs
, ...
}: {
  imports = [
    ./nix.nix
  ];

  nix = {
    settings = {
      auto-optimise-store = true;
    };
  };

  nixpkgs.config.allowUnfree = true;

  system.autoUpgrade = {
    enable = true;
  };
}